Articles - MiniDisc / MD

Sony MDS-B5 - Ne démarre pas - Diagnostic

  |   1001  |   Poster commentaire  |  MiniDisc / MD
Une ch'tite MDS-B5 trouvée sur eBay qui stagnait depuis un moment... à croire que vraiment personne ne cherche à prendre en charge ces bestioles.
Symptôme : une fois branchée, la platine n'affiche rien sur le VFD (pas de message "System Check" habituel) et le bouton REC clignote rouge.

La courroie a été remplacée en préventif, elle ne s'est pas encore transformée en substance collante mais ça n'allait pas tarder vu comme elle brille.

Le connecteur du moteur et des switches CN102 a eu ses soudures de refaites. Aucune idée du pourquoi.
Le problème n'a rien à voir avec le bloc mécanique, même sans bloc mécanique de connecté, le bouton REC ne devrait pas clignoter.

Tous les fusibles sont bons.

Ayant déjà une autre MDS-B5 100% fonctionnelle, je fais des tests croisés. J'ai branché l'écran de la platine en panne sur l'autre et il fonctionne bien.


Le problème provient donc de la carte "DIG BOARD" qui embarque pas mal de choses. Je me concentre sur elle. Comme rien n'est affiché à l'écran je suspecte un problème de logique coté SYSCON M30600E8FP (IC301).

Il est bizarre que la séquence d'initialisation "System Check" ne démarre même pas sur le VFD, c'est comme si visuellement la platine n'arriverait pas à "booter". Après vérifications toutes les tensions sont présentes et le quartz oscille.



Qu'est ce qui peut donc empêcher un microcontrôleur de lancer son programme normalement ? En fait si ça clignote c'est qu'il y a de la vie et qu'au moins du partie du soft s'exécute. Une touche de coincée sur la façade ? Ben non puisqu'elle l'écran fonctionne bien en test croisé avec l'autre DIG BOARD. Et bien en fait si ! J'ai pu reproduire la même chose avec ma platine fonctionnelle.

Si on maintient la touche REC ou EJECT appuyée quand on branche le secteur, j'ai le même comportement sur mon autre machine. Je rappelle que maintenir des touches appuyées quand on met le courant est un moyen, notamment sur les platines MD Sony (mais pas que), de rentrer dans le mode service par exemple (ou d'autres modes de démarrages spéciaux).
Après contrôle il s'avère que j'ai bien 5V sur les broches KEY1 et KEY2 mais à peine 500mV sur KEY0 (quand la façade est branchée). Emplacement des points de tests KEYx :


Et bizarrement KEY0 correspond aux touches REC, STOP et EJECT sur le schéma.

Le 5V utilisé par les touches est fourni par le DIG5V. Est-ce que le condensateur C301 serait en court-circuit vers la masse ? Réponse : Non. Ce serait trop facile. :lol

En gros, l'entrée KEY0 (broche 89) de l'IC301 a été flinguée. La seule explication possible, le technicien qui est passé avant à fait un court-circuit, à tout hasard, il a certainement mal rebranché la nappe de la façade et a envoyé le DISP5V sur la broche juste à coté (broche 5 -> 6). Simple hypothèse. :D

Malheureusement le microcontrôleur est spécifique à cet appareil. Ce qui fait que ce spécimen restera en l'état, hors service, le temps éventuellement de trouver une autre B5 ou B6P en panne pour y prélever son IC301. Un lot de consolation tout de même, l'écran VFD ainsi que le bloc optique KMS-210A sont en très bon état. Ce qui est plutôt rare sur ces machines. Image du bloc mécanique temporairement posé et connecté sur mon spécimen fonctionnel, les valeurs C1 CPLAY MODE sont OK en mode service aussi. :top

En attendant, retrait du condensateur de sauvegarde de type Gold-Cap en C34 de 1F qui s'est mis à couler, un classique dans nombre d’appareils.

Il ne sert qu'en cas de coupure de courant lors d'un enregistrement, histoire de ne pas perdre la TOC en RAM de ce qui vient d'être enregistré sur le MD.